CVE-2026-61372 Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions

High 7.5 Published Updated

Attackers can escape file restrictions via SPARQL Update requests in Apache Jena Fuseki, potentially reading or modifying unauthorized files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-61372?

CVE-2026-61372 is a high-severity path traversal vulnerability in Apache Jena Fuseki, published on 3 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki.

This issue affects Apache Jena Fuseki: through 6.1.0.

Users are recommended to upgrade to version 6.2.0, which fixes the issue.

Weakness: CWE-22

Which versions are affected by CVE-2026-61372?

It affects 1 product.

Products include Apache Jena Fuseki.

How do I fix CVE-2026-61372?

No fix has been published for CVE-2026-61372 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-61372 being exploited?

There is no known exploitation of CVE-2026-61372 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-61372, GHSA-g2qm-wc55-9539, UBUNTU-CVE-2026-61372.

Is CVE-2026-61372 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free