CVE-2026-61397 Apache CloudStack: OAuth2 Token Cross-Request Leak

High 7.5 Published Updated

Attackers can leak OAuth2 tokens across requests in Apache CloudStack, potentially leading to unauthorized access and data exposure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-61397?

CVE-2026-61397 is a high-severity vulnerability in Apache Cloudstack, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's OAuth2 authentication plugin and Google OAuth integration.

This issue affects Apache CloudStack: from 4.19.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1, which fixes the issue.

Weakness: CWE-200

Which versions are affected by CVE-2026-61397?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-61397?

No fix has been published for CVE-2026-61397 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-61397 being exploited?

There is no known exploitation of CVE-2026-61397 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-ppcf-cpj8-62xr.

Is CVE-2026-61397 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free