CVE-2026-61398 Apache CloudStack: Cross-Site Scripting (XSS) Vulnerability in Instance Reset Password Function in UI

Critical 9.1 Published Updated

Attackers can inject malicious scripts via the Instance Reset Password function in the Apache CloudStack UI, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-61398?

CVE-2026-61398 is a critical cross-site scripting vulnerability in Apache Cloudstack, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Instance Reset Password functionality.

This issue affects Apache CloudStack: from 4.15.1.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-116

Which versions are affected by CVE-2026-61398?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-61398?

No fix has been published for CVE-2026-61398 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-61398 being exploited?

There is no known exploitation of CVE-2026-61398 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-9xgp-62vf-q3qv.

Is CVE-2026-61398 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free