CVE-2026-61399 Apache CloudStack: Cross-Site Scripting (XSS) Vulnerability in Lock User Function in UI

Medium 4.8 Published Updated

Attackers can execute arbitrary scripts in the CloudStack UI via the Lock User function, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-61399?

CVE-2026-61399 is a medium-severity cross-site scripting vulnerability in Apache Cloudstack, published on 21 Aug 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Lock User Functionality.

This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-116

Which versions are affected by CVE-2026-61399?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-61399?

No fix has been published for CVE-2026-61399 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-61399 being exploited?

There is no known exploitation of CVE-2026-61399 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-4rrq-73x5-wj26.

Is CVE-2026-61399 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free