CVE-2026-61400 Apache CloudStack: Get and Run Diagnostics Command Injection

High 8.8 Published Updated

Authenticated admins can execute arbitrary commands as root on system VMs and virtual routers via diagnostics APIs, enabling full instance compromise.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-61400?

CVE-2026-61400 is a high-severity command injection vulnerability in Apache Cloudstack, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache CloudStack's run and get diagnostics functionality for the system VMs and virtual routers.

An authenticated user holding the permissions required to invoke either `getDiagnosticsData` or `runDiagnostics` can achieve arbitrary command execution on the system VM and/or Virtual Router instances, with commands running as root (or as the diagnostics-process user, at minimum). This represents a full compromise of the affected instance and, depending on network segmentation, may provide a foothold for lateral movement within the CloudStack-managed infrastructure, including access to guest network traffic handled by the compromised Virtual Router.

The getDiagnosticsData and runDiagnostics APIs are restricted to only Admin role accounts by default.

This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-77

Which versions are affected by CVE-2026-61400?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-61400?

No fix has been published for CVE-2026-61400 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-61400 being exploited?

There is no known exploitation of CVE-2026-61400 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-g382-2jw5-f8xr.

Is CVE-2026-61400 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free