# CVE-2026-61400: Apache CloudStack: Get and Run Diagnostics Command Injection

> Authenticated admins can execute arbitrary commands as root on system VMs and virtual routers via diagnostics APIs, enabling full instance compromise.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Aug 2026
- **Updated:** 22 Aug 2026
- **Also known as:** GHSA-g382-2jw5-f8xr

## What is CVE-2026-61400?

CVE-2026-61400 is a high-severity command injection vulnerability in Apache Cloudstack, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache CloudStack's run and get diagnostics functionality for the system VMs and virtual routers.

An authenticated user holding the permissions required to invoke either `getDiagnosticsData` or `runDiagnostics` can achieve arbitrary command execution on the system VM and/or Virtual Router instances, with commands running as root (or as the diagnostics-process user, at minimum). This represents a full compromise of the affected instance and, depending on network segmentation, may provide a foothold for lateral movement within the CloudStack-managed infrastructure, including access to guest network traffic handled by the compromised Virtual Router.

The getDiagnosticsData and runDiagnostics APIs are restricted to only Admin role accounts by default.

This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-61400?

It affects 1 product.


Products: Apache Cloudstack.

## How do I fix CVE-2026-61400?

No fix has been published for CVE-2026-61400 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-61400 being exploited?

There is no known exploitation of CVE-2026-61400 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cloudstack

- [CVE-2012-4501](https://insights.sbomify.com/CVE-2012-4501/): Missing authorization in n/a (critical 10.0)
- [CVE-2024-38346](https://insights.sbomify.com/CVE-2024-38346/): Apache CloudStack: Unauthenticated cluster service port leads to remote execution (critical 9.8)
- [CVE-2024-39864](https://insights.sbomify.com/CVE-2024-39864/): Apache CloudStack: Integration API service uses dynamic port when disabled (critical 9.8)
- [CVE-2024-29006](https://insights.sbomify.com/CVE-2024-29006/): Apache CloudStack: x-forwarded-for HTTP header parsed by default (critical 9.8)
- [CVE-2022-35741](https://insights.sbomify.com/CVE-2022-35741/): Apache CloudStack SAML Single Sign-On XXE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61400 and fix it if it is affected.

What it is: CVE-2026-61400 is a high-severity command injection vulnerability in Apache Cloudstack, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61400 in the wild and no public exploit code.

Affected product: Apache Cloudstack. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61400/ (Markdown: https://insights.sbomify.com/CVE-2026-61400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61400
- OSV: https://osv.dev/vulnerability/CVE-2026-61400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61400/
Summaries are generated and may contain mistakes; the official description above is the record.
