# CVE-2026-61426: PraisonAI before 1.7.3 Unauthenticated Agent Access via Insecure Defaults

> Unauthenticated attackers can access agent instructions and invoke agents due to insecure default network and authentication settings in PraisonAI.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-6wjp-v33h-5cvq

## What is CVE-2026-61426?

CVE-2026-61426 is a high-severity vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI before 1.7.3 contains an insecure default configuration that binds to all interfaces with no API key requirement and wildcard CORS. Unauthenticated attackers can call GET /api/agents to read agent instructions and system prompts, or POST /api/chat to invoke agents without authentication.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-61426?

2 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | npm | All versions | 1.7.3 |
| `praisonai` | npm | All versions | 1.7.3 |

## How do I fix CVE-2026-61426?

Upgrade praisonai to 1.7.3 or later.

## Is CVE-2026-61426 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61426 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61426 and fix it if it is affected.

What it is: CVE-2026-61426 is a high-severity vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61426 exists.

Affected packages and fixed versions:
- praisonai (npm): affected all versions; fixed in 1.7.3
- praisonai (npm): affected all versions; fixed in 1.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61426/ (Markdown: https://insights.sbomify.com/CVE-2026-61426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61426
- OSV: https://osv.dev/vulnerability/CVE-2026-61426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61426/
Summaries are generated and may contain mistakes; the official description above is the record.
