# CVE-2026-61429: PraisonAI before 1.6.78 SSRF via Crawl4AI Chromium backend

> Attackers can bypass SSRF validation in PraisonAI to access internal services and read sensitive data via DNS rebinding and redirects.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-6g59-gm2v-qhvq, PYSEC-2026-4269

## What is CVE-2026-61429?

CVE-2026-61429 is a high-severity server-side request forgery vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI versions before 1.6.78 contain a server-side request forgery vulnerability in the Crawl4AI/Chromium backend that allows attackers to bypass SSRF validation by exploiting DNS rebinding and HTTP redirects. Attackers can craft URLs that resolve to internal services after the initial validation check, enabling the headless browser to follow redirects and read internal responses including sensitive canary values.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-61429?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |

## How do I fix CVE-2026-61429?

Upgrade praisonaiagents to 1.6.78 or later.

## Is CVE-2026-61429 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61429 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61429 and fix it if it is affected.

What it is: CVE-2026-61429 is a high-severity server-side request forgery vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61429 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61429/ (Markdown: https://insights.sbomify.com/CVE-2026-61429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61429
- OSV: https://osv.dev/vulnerability/CVE-2026-61429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61429/
Summaries are generated and may contain mistakes; the official description above is the record.
