# CVE-2026-61431: PraisonAI before 4.6.78 Path Traversal via ContextGatherer

> Attackers can read arbitrary files outside the workspace by supplying malicious paths in context files, exposing sensitive data.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-q7m5-3jmv-vm48, PYSEC-2026-4258

## What is CVE-2026-61431?

CVE-2026-61431 is a medium-severity path traversal vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI before 4.6.78 contains a path traversal vulnerability in ContextGatherer that fails to validate include paths in .praisoncontext and .praisoninclude files. Attackers can supply absolute paths or parent directory traversal sequences to read arbitrary files outside the workspace and include their contents in the generated context bundle.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-61431?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-61431?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-61431 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61431 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61431 and fix it if it is affected.

What it is: CVE-2026-61431 is a medium-severity path traversal vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61431 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61431/ (Markdown: https://insights.sbomify.com/CVE-2026-61431/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61431
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61431
- OSV: https://osv.dev/vulnerability/CVE-2026-61431

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61431/
Summaries are generated and may contain mistakes; the official description above is the record.
