# CVE-2026-61433: PraisonAI before 4.6.78 Code Injection via API deployment generator

> Attackers can inject arbitrary Python code via configuration parameters in PraisonAI, leading to remote code execution when the generated server runs.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CVE-2026-62173, GHSA-79fv-7hq9-w7xg, PYSEC-2026-4251

## What is CVE-2026-61433?

CVE-2026-61433 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI before 4.6.78 fails to safely encode deployment configuration values when generating Python source code for API servers. Attackers can inject arbitrary Python expressions through the deploy.api.host and agents_file configuration parameters that execute when the generated server starts or handles requests.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-61433?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-61433?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-61433 being exploited?

There is no known exploitation of CVE-2026-61433 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61433 and fix it if it is affected.

What it is: CVE-2026-61433 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-61433 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61433/ (Markdown: https://insights.sbomify.com/CVE-2026-61433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61433
- OSV: https://osv.dev/vulnerability/CVE-2026-61433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61433/
Summaries are generated and may contain mistakes; the official description above is the record.
