# CVE-2026-61434: PraisonAI before 4.6.78 Allowlist Bypass via find -exec

> Attackers can bypass command allowlists in PraisonAI to execute arbitrary binaries, read, or delete files via find command actions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-cv3g-hj65-pcfh, PYSEC-2026-4254

## What is CVE-2026-61434?

CVE-2026-61434 is a high-severity command injection vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI versions before 4.6.78 contain an allowlist bypass vulnerability in shell command execution that allows attackers to execute restricted commands via find's built-in -exec, -execdir, and -delete actions. Attackers can craft find commands with these built-in actions to read blocked files, delete files, or execute non-allowlisted binaries without triggering shell metacharacter filters.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-61434?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-61434?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-61434 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61434 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61434 and fix it if it is affected.

What it is: CVE-2026-61434 is a high-severity command injection vulnerability in MervinPraison PraisonAI, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61434 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61434/ (Markdown: https://insights.sbomify.com/CVE-2026-61434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61434
- OSV: https://osv.dev/vulnerability/CVE-2026-61434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61434/
Summaries are generated and may contain mistakes; the official description above is the record.
