# CVE-2026-61436: PraisonAI before 4.6.78 Missing Webhook Signature Verification

> Attackers can forge webhook events to invoke AI agents with arbitrary content due to missing signature verification in PraisonAI.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CVE-2026-62172, GHSA-7c92-x8vg-4258, PYSEC-2026-4252

## What is CVE-2026-61436?

CVE-2026-61436 is a high-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI before 4.6.78 fails to verify Svix webhook signatures in AgentMail webhook mode, allowing unauthenticated attackers to forge message.received events. Attackers can send crafted JSON payloads to the webhook endpoint to invoke configured agents with arbitrary sender addresses and message content.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-61436?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-61436?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-61436 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61436 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61436 and fix it if it is affected.

What it is: CVE-2026-61436 is a high-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61436 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61436/ (Markdown: https://insights.sbomify.com/CVE-2026-61436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61436
- OSV: https://osv.dev/vulnerability/CVE-2026-61436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61436/
Summaries are generated and may contain mistakes; the official description above is the record.
