# CVE-2026-61438: PraisonAI before 4.6.78 Remote Code Execution via Broken AST Sandbox

> Attackers can execute arbitrary OS commands by bypassing AST sandbox checks in PraisonAI workflow scripts, allowing remote code execution.

- **Severity:** High 7.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CVE-2026-62248, GHSA-26mh-57q7-jfvr

## What is CVE-2026-61438?

CVE-2026-61438 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI before 4.6.78 contains a remote code execution vulnerability in JobWorkflowExecutor._exec_inline_python() due to insufficient AST validation of workflow script steps. Attackers can create malicious YAML workflow files with import os statements followed by os.system() calls that bypass sandbox checks and execute arbitrary OS commands with process privileges.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-61438?

2 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-61438?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-61438 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61438 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61438 and fix it if it is affected.

What it is: CVE-2026-61438 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61438 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61438/ (Markdown: https://insights.sbomify.com/CVE-2026-61438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61438
- OSV: https://osv.dev/vulnerability/CVE-2026-61438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61438/
Summaries are generated and may contain mistakes; the official description above is the record.
