# CVE-2026-61439: PraisonAI before 4.6.78 Prompt Injection Defense Bypass

> Attackers can bypass prompt injection defenses in PraisonAI to extract system prompts and invoke unauthorized tools due to a misconfigured blocking threshold.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-fj8f-m44g-c479, PYSEC-2026-4255

## What is CVE-2026-61439?

CVE-2026-61439 is a high-severity vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI versions before 4.6.78 contain a prompt injection defense misconfiguration where the block threshold defaults to CRITICAL severity, allowing HIGH-level threats to pass through unblocked. Attackers can submit single-vector prompt injection attacks such as instruction overrides or financial manipulation that trigger HIGH severity detection but are logged without blocking, enabling system prompt extraction and unauthorized tool invocations.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-61439?

3 open source packages ship an affected version, including praisonai and PraisonAI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `PraisonAI` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-61439?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-61439 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61439 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61439 and fix it if it is affected.

What it is: CVE-2026-61439 is a high-severity vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61439 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- PraisonAI (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61439/ (Markdown: https://insights.sbomify.com/CVE-2026-61439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61439
- OSV: https://osv.dev/vulnerability/CVE-2026-61439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61439/
Summaries are generated and may contain mistakes; the official description above is the record.
