# CVE-2026-61440: PraisonAI Platform before 0.1.9 Authorization Bypass via Label Endpoints


- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** CVE-2026-62180, GHSA-xxgv-vgvj-qvxh, PYSEC-2026-4264

## What is CVE-2026-61440?

CVE-2026-61440 is a high-severity vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. 

### Official description

PraisonAI Platform before 0.1.9 fails to properly authorize label and issue-label mutations, allowing workspace members to rename and recolor shared labels and add or remove labels on owner-created issues. Attackers with workspace member privileges can exploit PATCH and POST/DELETE endpoints to alter shared label taxonomy and manipulate issue-label associations without owner or admin authorization.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-61440?

3 open source packages ship an affected version, including praisonai-platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai-platform` | PyPI | All versions | 0.1.9 |
| `praisonai-platform` | PyPI | All versions | 0.1.9 |
| `praisonai-platform` | PyPI | All versions | 0.1.9 |

## How do I fix CVE-2026-61440?

Upgrade praisonai-platform to 0.1.9 or later.

## Is CVE-2026-61440 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61440 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61440 and fix it if it is affected.

What it is: CVE-2026-61440 is a high-severity vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61440 exists.

Affected packages and fixed versions:
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.9
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.9
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61440/ (Markdown: https://insights.sbomify.com/CVE-2026-61440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61440
- OSV: https://osv.dev/vulnerability/CVE-2026-61440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61440/
Summaries are generated and may contain mistakes; the official description above is the record.
