# CVE-2026-61445: PraisonAI before 4.6.78 Arbitrary File Write and Command Execution

> Attackers can inject prompts to write arbitrary files and execute shell commands with root privileges in PraisonAI's AICoder component.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-9mp3-24cc-77mg, PYSEC-2026-4253

## What is CVE-2026-61445?

CVE-2026-61445 is a critical path traversal vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI before 4.6.78 contains arbitrary file write and command execution vulnerabilities in the AICoder component due to missing path validation and command sanitization in LLM tool calls. Attackers can inject malicious prompts through the chat interface to write files to arbitrary filesystem locations and execute arbitrary shell commands with root privileges.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-61445?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |
| `praisonai` | PyPI | All versions | 4.6.78 |

## How do I fix CVE-2026-61445?

Upgrade praisonai to 4.6.78 or later.

## Is CVE-2026-61445 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61445 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61445 and fix it if it is affected.

What it is: CVE-2026-61445 is a critical path traversal vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61445 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78
- praisonai (PyPI): affected all versions; fixed in 4.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61445/ (Markdown: https://insights.sbomify.com/CVE-2026-61445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61445
- OSV: https://osv.dev/vulnerability/CVE-2026-61445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61445/
Summaries are generated and may contain mistakes; the official description above is the record.
