# CVE-2026-61446: PraisonAI before 1.6.78 Remote Code Execution via Plugin Auto-Discovery

> Attackers can achieve arbitrary code execution by placing malicious Python files in plugin directories, affecting PraisonAI users.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CVE-2026-62165, GHSA-m6wp-h223-4c8g, PYSEC-2026-4271

## What is CVE-2026-61446?

CVE-2026-61446 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAI (praisonaiagents) before 1.6.78 contains a remote code execution vulnerability in the plugin manager, which loads and executes arbitrary Python (.py) files from project-level and user-home .praisonai/plugins/ directories using importlib spec_from_file_location() and exec_module() without code signing, integrity verification, or sandboxing. An attacker who can write a malicious .py file to a plugin directory (for example via path traversal, a supply chain attack, or a compromised dependency) achieves arbitrary code execution when the plugin system initializes.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-61446?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |

## How do I fix CVE-2026-61446?

Upgrade praisonaiagents to 1.6.78 or later.

## Is CVE-2026-61446 being exploited?

There is no known exploitation of CVE-2026-61446 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61446 and fix it if it is affected.

What it is: CVE-2026-61446 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61446 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61446/ (Markdown: https://insights.sbomify.com/CVE-2026-61446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61446
- OSV: https://osv.dev/vulnerability/CVE-2026-61446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61446/
Summaries are generated and may contain mistakes; the official description above is the record.
