# CVE-2026-61447: PraisonAI before 1.6.78 Remote Code Execution via CodeAgent

> Attackers can execute arbitrary code and steal secrets by influencing LLM output in PraisonAI's CodeAgent due to missing sandboxing.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-2xv2-w8cq-5gxw, PYSEC-2026-4266

## What is CVE-2026-61447?

CVE-2026-61447 is a critical code injection vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI before 1.6.78 contains a remote code execution vulnerability in CodeAgent._execute_python() that executes LLM-generated Python code without AST validation, import restrictions, or sandbox enforcement. Attackers can influence LLM output through prompt injection to exfiltrate all environment secrets and execute arbitrary code on the host system.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-61447?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |
| `praisonaiagents` | PyPI | All versions | 1.6.78 |

## How do I fix CVE-2026-61447?

Upgrade praisonaiagents to 1.6.78 or later.

## Is CVE-2026-61447 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61447 exists.

Public exploit code:

- PraisonAI praisonaiagents  1.6.77 - Remote Code Execution (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61447 and fix it if it is affected.

What it is: CVE-2026-61447 is a critical code injection vulnerability in MervinPraison PraisonAI, published on 11 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61447 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61447/ (Markdown: https://insights.sbomify.com/CVE-2026-61447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61447
- OSV: https://osv.dev/vulnerability/CVE-2026-61447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61447/
Summaries are generated and may contain mistakes; the official description above is the record.
