CVE-2026-61448 Parse Server 9.0.0 Stored XSS via malformed Content-Type
Attackers can execute arbitrary scripts in other users' browsers by uploading files with malformed Content-Type headers when using specific cloud storage adapters.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-61448?
CVE-2026-61448 is a low-severity cross-site scripting vulnerability in parse-community parse-server, published on 11 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Parse Server is affected by a stored cross-site scripting (XSS) vulnerability in versions >= 9.0.0, < 9.10.0-alpha.2 and <= 8.6.83. When an uploaded file's extension is not recognized by the mime package, Parse Server preserves the client-supplied Content-Type. A malformed Content-Type that is not a valid type/subtype media type (e.g., 'image', 'image/', or 'image//svg+xml') bypasses the fileUpload.fileExtensions blocklist and is stored unchanged. On storage adapters that persist and serve the uploaded Content-Type (such as Amazon S3, Google Cloud Storage, or Azure Blob Storage), a browser cannot parse the malformed value and falls back to MIME-sniffing; a file whose body begins with HTML is rendered as HTML, executing embedded script in the application's origin against other users who open the file URL. The default GridFS storage adapter is not affected. Fixed in 9.10.0-alpha.2 and 8.6.84.
Weakness: CWE-434
Which versions are affected by CVE-2026-61448?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.84 |
parse-server npm | All versions | 8.6.84 |
parse-server npm | From 9.0.0 | 9.10.0-alpha.2 |
parse-server npm | From 9.0.0 | 9.10.0-alpha.2 |
parse Bitnami | All versions | 8.6.84, 9.10.0 |
How do I fix CVE-2026-61448?
Upgrade parse-server to a fixed version for your release line: 8.6.84 or 9.10.0-alpha.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-61448 being exploited?
There is no known exploitation of CVE-2026-61448 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2026-61448, GHSA-r899-h629-j84r.