{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61449 exists.","fix":"Upgrade getgrav/grav to 2.0.2 or later.","what":"CVE-2026-61449 is a high-severity denial of service vulnerability in getgrav grav, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-61449 and fix it if it is affected.\n\nWhat it is: CVE-2026-61449 is a high-severity denial of service vulnerability in getgrav grav, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61449 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected from 2.0.1; fixed in 2.0.2\n- getgrav/grav (Packagist): affected from 2.0.1; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-61449/ (Markdown: https://insights.sbomify.com/CVE-2026-61449/index.md)","id":"CVE-2026-61449","markdown":"https://insights.sbomify.com/CVE-2026-61449/index.md","name":"CVE-2026-61449","record":{"aliases":["CVE-2026-61841","GHSA-8h9x-89f2-m7x3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"none","summary":"Attacker can cause disk exhaustion via crafted ZIP archives in Grav CMS due to size cap bypass, requiring admin or package source trust.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"Grav 2.0.1 contains a decompression-bomb size-cap bypass in ZipArchiver and GPM\\Installer. The size bound introduced in 2.0.1 sums the uncompressed size declared in each entry's ZIP central-directory header (ZipArchive::statIndex()['size']) and rejects archives exceeding system.gpm.archive.max_uncompressed_size before extraction. Because this declared size is attacker-forgeable and is not cross-checked against the actual inflated stream, a crafted archive declaring tiny per-entry sizes passes the cap while extractTo() writes the real, much larger content, filling disk or exhausting inodes. The archive must be supplied by a package source or admin upload (admin/operator trust). Fixed in 2.0.2. This is an incomplete fix for GHSA-928x-9mpw-8h56.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav before 2.0.2 Decompression Bomb via Forged ZIP Size","id":"CVE-2026-61449","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Grav before 2.0.2 Config Exfiltration via offsetGet Filter","id":"CVE-2026-61450"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.2"],"introduced":["2.0.1"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-8h9x-89f2-m7x3"},{"ecosystem":"Packagist","fixed":["2.0.2"],"introduced":["2.0.1"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-8h9x-89f2-m7x3"}],"prev":{"headline":"Parse Server 9.0.0 Stored XSS via malformed Content-Type","id":"CVE-2026-61448"},"products":["grav"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"Attacker can cause disk exhaustion via crafted ZIP archives in Grav CMS due to size cap bypass, requiring admin or package source trust.","url":"https://insights.sbomify.com/CVE-2026-61449/"}