# CVE-2026-61449: Grav before 2.0.2 Decompression Bomb via Forged ZIP Size

> Attacker can cause disk exhaustion via crafted ZIP archives in Grav CMS due to size cap bypass, requiring admin or package source trust.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** CVE-2026-61841, GHSA-8h9x-89f2-m7x3

## What is CVE-2026-61449?

CVE-2026-61449 is a high-severity denial of service vulnerability in getgrav grav, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Grav 2.0.1 contains a decompression-bomb size-cap bypass in ZipArchiver and GPM\Installer. The size bound introduced in 2.0.1 sums the uncompressed size declared in each entry's ZIP central-directory header (ZipArchive::statIndex()['size']) and rejects archives exceeding system.gpm.archive.max_uncompressed_size before extraction. Because this declared size is attacker-forgeable and is not cross-checked against the actual inflated stream, a crafted archive declaring tiny per-entry sizes passes the cap while extractTo() writes the real, much larger content, filling disk or exhausting inodes. The archive must be supplied by a package source or admin upload (admin/operator trust). Fixed in 2.0.2. This is an incomplete fix for GHSA-928x-9mpw-8h56.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-61449?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | From 2.0.1 | 2.0.2 |
| `getgrav/grav` | Packagist | From 2.0.1 | 2.0.2 |

## How do I fix CVE-2026-61449?

Upgrade getgrav/grav to 2.0.2 or later.

## Is CVE-2026-61449 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61449 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61449 and fix it if it is affected.

What it is: CVE-2026-61449 is a high-severity denial of service vulnerability in getgrav grav, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61449 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected from 2.0.1; fixed in 2.0.2
- getgrav/grav (Packagist): affected from 2.0.1; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61449/ (Markdown: https://insights.sbomify.com/CVE-2026-61449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61449
- OSV: https://osv.dev/vulnerability/CVE-2026-61449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61449/
Summaries are generated and may contain mistakes; the official description above is the record.
