CVE-2026-61487 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authorization bypass via temporary composite destinations
Authenticated low-privilege users can bypass write ACLs and publish messages to protected queues by exploiting temporary composite destinations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-61487?
CVE-2026-61487 is a medium-severity authentication bypass vulnerability in Apache Activemq, published on 28 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.
An authenticated low-privilege user can bypass a per-destination write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary. This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8.
Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.
Weakness: CWE-285
Which versions are affected by CVE-2026-61487?
1 open source package ship an affected version, including activemq. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
activemq Bitnami | All versions | 5.19.9, 6.2.8 |
Products include Apache Activemq, Apache Activemq All, Apache Activemq Broker.
How do I fix CVE-2026-61487?
Upgrade activemq to a fixed version for your release line: 5.19.9 or 6.2.8.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-61487 being exploited?
There is no known exploitation of CVE-2026-61487 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-61487, DEBIAN-CVE-2026-61487, GHSA-xmcq-x3wj-p8v6, MINI-3wx3-qc4w-hv3h, MINI-4f6c-8mp7-r8j5, MINI-cvfh-rhh4-4g5v and 4 more.