# CVE-2026-61487: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authorization bypass via temporary composite destinations

> Authenticated low-privilege users can bypass write ACLs and publish messages to protected queues by exploiting temporary composite destinations.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** BIT-activemq-2026-61487, DEBIAN-CVE-2026-61487, GHSA-xmcq-x3wj-p8v6, MINI-3wx3-qc4w-hv3h, MINI-4f6c-8mp7-r8j5, MINI-cvfh-rhh4-4g5v, MINI-p456-4456-jhcv, MINI-pgxw-rwjr-hw5c, MINI-wpm8-4w9c-45fq, UBUNTU-CVE-2026-61487

## What is CVE-2026-61487?

CVE-2026-61487 is a medium-severity authentication bypass vulnerability in Apache Activemq, published on 28 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authorization vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ.

 An authenticated low-privilege user can bypass a per-destination
write ACL by sending to an ActiveMQ temporary composite destination whose physical name is a
comma-separated composite of real queues. This allows publishing messages to any of the destinations in the list without proper write ACL permissions because the authorization check is bypassed due to the composite destination being marked as temporary.
This issue affects Apache ActiveMQ Broker: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8.

Users are recommended to upgrade to version 5.19.9, 6.2.8 or 6.3.0, which fixes the issue.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-61487?

1 open source package ship an affected version, including activemq. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions | 5.19.9, 6.2.8 |

Products: Apache Activemq, Apache Activemq All, Apache Activemq Broker.

## How do I fix CVE-2026-61487?

Upgrade activemq to a fixed version for your release line: 5.19.9 or 6.2.8.

## Is CVE-2026-61487 being exploited?

There is no known exploitation of CVE-2026-61487 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61487 and fix it if it is affected.

What it is: CVE-2026-61487 is a medium-severity authentication bypass vulnerability in Apache Activemq, published on 28 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61487 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions; fixed in 5.19.9, 6.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61487/ (Markdown: https://insights.sbomify.com/CVE-2026-61487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61487
- OSV: https://osv.dev/vulnerability/CVE-2026-61487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61487/
Summaries are generated and may contain mistakes; the official description above is the record.
