{"answers":{"affected":"3 open source packages ship an affected version, including xinference.","exploited":"There is no known exploitation of CVE-2026-61539 in the wild and no public exploit code.","fix":"Upgrade xinference to 2.7.0 or later.","what":"CVE-2026-61539 is a critical code injection vulnerability in xorbitsai inference, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-61539 and fix it if it is affected.\n\nWhat it is: CVE-2026-61539 is a critical code injection vulnerability in xorbitsai inference, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-61539 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- xinference (PyPI): affected all versions; fixed in 2.7.0\n- xinference (PyPI): affected all versions; fixed in 2.7.0\n- xinference (PyPI): affected all versions; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-61539/ (Markdown: https://insights.sbomify.com/CVE-2026-61539/index.md)","id":"CVE-2026-61539","markdown":"https://insights.sbomify.com/CVE-2026-61539/index.md","name":"CVE-2026-61539","record":{"aliases":["GHSA-x2rj-828p-hx9m","PYSEC-2026-3946"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AI inference API","requires_auth":"none","summary":"An unauthenticated remote attacker can execute arbitrary code on the Xinference server by crafting prompts that trigger unsafe eval() in Llama3 tool-call parsing.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"Xinference is an inference API for running open-source, speech, and multimodal models. In 2.5.0 and earlier, Xinference passes attacker-influenced Llama3 tool-call output to eval() in xinference/model/llm/tool_parsers/llama3_tool_parser.py and xinference/model/llm/utils.py. Requests to /v1/chat/completions with a tools field flow through xinference/api/restful_api.py, xinference/model/llm/transformers/core.py, handle_chat_result_non_streaming(), and _post_process_completion() before extract_tool_calls() or _eval_llama3_chat_arguments() evaluates the model-generated Python expression. An unauthenticated remote attacker can influence that output through a crafted prompt and execute commands in the Xinference server process context. This issue is fixed in version 2.7.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Xinference: Remote code execution via unsafe `eval()` in Llama3 tool-call parsing","id":"CVE-2026-61539","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Zapros has an Unbounded Content-Encoding decompression chain that allows denial of service","id":"CVE-2026-61541"},"packages":[{"ecosystem":"PyPI","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"xinference","purl":null,"source":"GHSA-x2rj-828p-hx9m"},{"ecosystem":"PyPI","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"xinference","purl":"pkg:pypi/xinference","source":"GHSA-x2rj-828p-hx9m"},{"ecosystem":"PyPI","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"xinference","purl":"pkg:pypi/xinference","source":"PYSEC-2026-3946"}],"prev":{"headline":"Banks: Unsafe importlib.import_module of attacker-controlled Tool.import_path in CompletionExtension allows RCE","id":"CVE-2026-61536"},"products":["inference"],"published":"2026-08-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["xorbitsai"]},"summary":"An unauthenticated remote attacker can execute arbitrary code on the Xinference server by crafting prompts that trigger unsafe eval() in Llama3 tool-call parsing.","url":"https://insights.sbomify.com/CVE-2026-61539/"}