# CVE-2026-61541: Zapros has an Unbounded Content-Encoding decompression chain that allows denial of service

> A malicious server can cause denial of service in Zapros by sending excessive chained Content-Encoding headers, exhausting resources during decompression.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-5vjj-2r48-q622, PYSEC-2026-4181

## What is CVE-2026-61541?

CVE-2026-61541 is a medium-severity denial of service vulnerability in kap-sh zapros, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zapros, a Python HTTP client, prior to version 0.14.0 is vulnerable to denial of service when an application requests content from an untrusted server, or follows a redirect to one, because a malicious response containing an excessive number of chained `Content-Encoding` values causes Zapros to construct a deeply nested decompression chain that consumes excessive resources. Version 0.14.0 patches the vulnerability by limiting responses to five content-encoding layers and raising `DecodingError` when that limit is exceeded. As a workaround, applications can add response middleware that inspects the `Content-Encoding` header and rejects responses containing more than a safe number of encoding layers.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-61541?

3 open source packages ship an affected version, including zapros.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zapros` | PyPI | All versions | 0.14.0 |
| `zapros` | PyPI | All versions | 0.14.0 |
| `zapros` | PyPI | All versions | 0.14.0 |

## How do I fix CVE-2026-61541?

Upgrade zapros to 0.14.0 or later.

## Is CVE-2026-61541 being exploited?

There is no known exploitation of CVE-2026-61541 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61541 and fix it if it is affected.

What it is: CVE-2026-61541 is a medium-severity denial of service vulnerability in kap-sh zapros, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61541 in the wild and no public exploit code.

Affected packages and fixed versions:
- zapros (PyPI): affected all versions; fixed in 0.14.0
- zapros (PyPI): affected all versions; fixed in 0.14.0
- zapros (PyPI): affected all versions; fixed in 0.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61541/ (Markdown: https://insights.sbomify.com/CVE-2026-61541/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61541
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61541
- OSV: https://osv.dev/vulnerability/CVE-2026-61541

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61541/
Summaries are generated and may contain mistakes; the official description above is the record.
