# CVE-2026-61544: libp2p-quic: Remote panic via certificate expiry race during QUIC handshake

> A remote attacker can cause a denial of service by triggering a panic in the libp2p-quic handshake process via a race condition involving certificate expiry.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-5hq8-qhww-jm7q, UBUNTU-CVE-2026-61544

## What is CVE-2026-61544?

CVE-2026-61544 is a high-severity denial of service vulnerability in rust-libp2p, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-61544?

2 open source packages ship an affected version, including libp2p-quic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libp2p-quic` | crates.io | All versions | 0.13.1 |
| `libp2p-quic` | crates.io | All versions | 0.13.1 |

## How do I fix CVE-2026-61544?

Upgrade libp2p-quic to 0.13.1 or later.

## Is CVE-2026-61544 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61544 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61544 and fix it if it is affected.

What it is: CVE-2026-61544 is a high-severity denial of service vulnerability in rust-libp2p, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61544 exists.

Affected packages and fixed versions:
- libp2p-quic (crates.io): affected all versions; fixed in 0.13.1
- libp2p-quic (crates.io): affected all versions; fixed in 0.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61544/ (Markdown: https://insights.sbomify.com/CVE-2026-61544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61544
- OSV: https://osv.dev/vulnerability/CVE-2026-61544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61544/
Summaries are generated and may contain mistakes; the official description above is the record.
