# CVE-2026-61549: Woodpecker: Privilege escalation via unrestricted serviceAccountName in the Kubernetes backend

> Attackers with push access can escalate privileges by specifying arbitrary Kubernetes ServiceAccounts, potentially leading to cluster takeover and secret exfiltration.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-qf34-295c-26v8, GO-2026-5992

## What is CVE-2026-61549?

CVE-2026-61549 is a critical vulnerability in woodpecker-ci woodpecker, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Woodpecker is a CI/CD engine. From 1.0.0 until 3.16.0, pipeline/backend/kubernetes/backend_options.go defines backend_options.kubernetes.serviceAccountName, and the Kubernetes backend in pipeline/backend/kubernetes/pod.go copies that pipeline-step value directly into the pod specification without administrator authorization. Any user with Push permission on a connected repository can therefore run pipeline pods under an arbitrary ServiceAccount in the pipeline namespace and inherit that account's RBAC permissions. When a privileged ServiceAccount is reachable, the attacker can exfiltrate secrets such as database credentials, API keys, and TLS certificates and may take over the cluster. This issue is fixed in version 3.16.0.

Weakness: CWE-862 (Missing Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-61549?

10 open source packages ship an affected version, including github.com/woodpecker-ci/woodpecker, go.woodpecker-ci.org/woodpecker and go.woodpecker-ci.org/woodpecker/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/woodpecker-ci/woodpecker` | Go | From 1.0.0 | None |
| `github.com/woodpecker-ci/woodpecker` | Go | From 1.0.0 to 1.0.4 | None |
| `github.com/woodpecker-ci/woodpecker` | Go | From 1.0.0 to 1.0.4 | None |
| `go.woodpecker-ci.org/woodpecker` | Go | All versions | None |
| `go.woodpecker-ci.org/woodpecker/v2` | Go | All versions | None |
| `go.woodpecker-ci.org/woodpecker/v2` | Go | All versions to 2.8.3 | None |
| `go.woodpecker-ci.org/woodpecker/v2` | Go | All versions to 2.8.3 | None |
| `go.woodpecker-ci.org/woodpecker/v3` | Go | All versions | 3.16.0 |
| `go.woodpecker-ci.org/woodpecker/v3` | Go | All versions | 3.16.0 |
| `go.woodpecker-ci.org/woodpecker/v3` | Go | All versions | 3.16.0 |

## How do I fix CVE-2026-61549?

Upgrade to a fixed version.

## Is CVE-2026-61549 being exploited?

There is no known exploitation of CVE-2026-61549 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61549 and fix it if it is affected.

What it is: CVE-2026-61549 is a critical vulnerability in woodpecker-ci woodpecker, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61549 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/woodpecker-ci/woodpecker (Go): affected from 1.0.0; no fix listed
- github.com/woodpecker-ci/woodpecker (Go): affected from 1.0.0 up to 1.0.4; no fix listed
- github.com/woodpecker-ci/woodpecker (Go): affected from 1.0.0 up to 1.0.4; no fix listed
- go.woodpecker-ci.org/woodpecker (Go): affected all versions; no fix listed
- go.woodpecker-ci.org/woodpecker/v2 (Go): affected all versions; no fix listed
- go.woodpecker-ci.org/woodpecker/v2 (Go): affected all versions up to 2.8.3; no fix listed
- go.woodpecker-ci.org/woodpecker/v2 (Go): affected all versions up to 2.8.3; no fix listed
- go.woodpecker-ci.org/woodpecker/v3 (Go): affected all versions; fixed in 3.16.0
- go.woodpecker-ci.org/woodpecker/v3 (Go): affected all versions; fixed in 3.16.0
- go.woodpecker-ci.org/woodpecker/v3 (Go): affected all versions; fixed in 3.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61549/ (Markdown: https://insights.sbomify.com/CVE-2026-61549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61549
- OSV: https://osv.dev/vulnerability/CVE-2026-61549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61549/
Summaries are generated and may contain mistakes; the official description above is the record.
