CVE-2026-61570 MPXJ: XXE Vulnerability in MerlinReader

High 7.5 Published Updated

An attacker can exploit an XXE vulnerability in MPXJ to read arbitrary local files via a crafted Merlin project database.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-61570?

CVE-2026-61570 is a high-severity vulnerability in joniles mpxj, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MPXJ is an open source library to read and write project plans from a variety of file formats and databases. From 5.5.5 until 16.4.1, MerlinReader creates a DocumentBuilder with default settings while parsing XML from the ZTIMEINTERVALS column of a Merlin project SQLite database, leaving doctype declarations and external entities enabled. A crafted database can cause the parser to read an arbitrary local file, although MPXJ's subsequent handling of the parsed XML makes disclosure of the file contents unlikely. This issue is fixed in version 16.4.1.

Weakness: CWE-611

Which versions are affected by CVE-2026-61570?

15 open source packages ship an affected version, including mpxj, net.sf.mpxj:mpxj and MPXJ.Net.

PackageAffectedFixed in
mpxj PyPIFrom 5.5.516.4.1
mpxj PyPIFrom 5.5.516.4.1
mpxj PyPIFrom 5.5.516.4.1
mpxj RubyGemsFrom 5.5.516.4.1
mpxj RubyGemsFrom 5.5.516.4.1
net.sf.mpxj:mpxj MavenFrom 5.5.516.4.1
9 more packages
net.sf.mpxj:mpxj MavenFrom 5.5.516.4.1
MPXJ.Net NuGetFrom 5.5.516.4.1
MPXJ.Net NuGetFrom 5.5.516.4.1
net.sf.mpxj NuGetFrom 5.5.516.4.1
net.sf.mpxj NuGetFrom 5.5.516.4.1
net.sf.mpxj-for-csharp NuGetFrom 5.5.516.4.1
net.sf.mpxj-for-csharp NuGetFrom 5.5.516.4.1
net.sf.mpxj-for-vb NuGetFrom 5.5.516.4.1
net.sf.mpxj-for-vb NuGetFrom 5.5.516.4.1

How do I fix CVE-2026-61570?

Upgrade mpxj to 16.4.1 or later.

Is CVE-2026-61570 being exploited?

There is no known exploitation of CVE-2026-61570 in the wild and no public exploit code.

Sources

Also known as GHSA-5vvx-3h34-f3gj, PYSEC-2026-4107.

Is CVE-2026-61570 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free