# CVE-2026-61570: MPXJ: XXE Vulnerability in MerlinReader

> An attacker can exploit an XXE vulnerability in MPXJ to read arbitrary local files via a crafted Merlin project database.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-5vvx-3h34-f3gj, PYSEC-2026-4107

## What is CVE-2026-61570?

CVE-2026-61570 is a high-severity vulnerability in joniles mpxj, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MPXJ is an open source library to read and write project plans from a variety of file formats and databases. From 5.5.5 until 16.4.1, MerlinReader creates a DocumentBuilder with default settings while parsing XML from the ZTIMEINTERVALS column of a Merlin project SQLite database, leaving doctype declarations and external entities enabled. A crafted database can cause the parser to read an arbitrary local file, although MPXJ's subsequent handling of the parsed XML makes disclosure of the file contents unlikely. This issue is fixed in version 16.4.1.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2026-61570?

15 open source packages ship an affected version, including mpxj, net.sf.mpxj:mpxj and MPXJ.Net.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mpxj` | PyPI | From 5.5.5 | 16.4.1 |
| `mpxj` | PyPI | From 5.5.5 | 16.4.1 |
| `mpxj` | PyPI | From 5.5.5 | 16.4.1 |
| `mpxj` | RubyGems | From 5.5.5 | 16.4.1 |
| `mpxj` | RubyGems | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj:mpxj` | Maven | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj:mpxj` | Maven | From 5.5.5 | 16.4.1 |
| `MPXJ.Net` | NuGet | From 5.5.5 | 16.4.1 |
| `MPXJ.Net` | NuGet | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj` | NuGet | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj` | NuGet | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj-for-csharp` | NuGet | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj-for-csharp` | NuGet | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj-for-vb` | NuGet | From 5.5.5 | 16.4.1 |
| `net.sf.mpxj-for-vb` | NuGet | From 5.5.5 | 16.4.1 |

## How do I fix CVE-2026-61570?

Upgrade mpxj to 16.4.1 or later.

## Is CVE-2026-61570 being exploited?

There is no known exploitation of CVE-2026-61570 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61570 and fix it if it is affected.

What it is: CVE-2026-61570 is a high-severity vulnerability in joniles mpxj, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61570 in the wild and no public exploit code.

Affected packages and fixed versions:
- mpxj (PyPI): affected from 5.5.5; fixed in 16.4.1
- mpxj (PyPI): affected from 5.5.5; fixed in 16.4.1
- mpxj (PyPI): affected from 5.5.5; fixed in 16.4.1
- mpxj (RubyGems): affected from 5.5.5; fixed in 16.4.1
- mpxj (RubyGems): affected from 5.5.5; fixed in 16.4.1
- net.sf.mpxj:mpxj (Maven): affected from 5.5.5; fixed in 16.4.1
- net.sf.mpxj:mpxj (Maven): affected from 5.5.5; fixed in 16.4.1
- MPXJ.Net (NuGet): affected from 5.5.5; fixed in 16.4.1
- MPXJ.Net (NuGet): affected from 5.5.5; fixed in 16.4.1
- net.sf.mpxj (NuGet): affected from 5.5.5; fixed in 16.4.1
- net.sf.mpxj (NuGet): affected from 5.5.5; fixed in 16.4.1
- net.sf.mpxj-for-csharp (NuGet): affected from 5.5.5; fixed in 16.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61570/ (Markdown: https://insights.sbomify.com/CVE-2026-61570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61570
- OSV: https://osv.dev/vulnerability/CVE-2026-61570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61570/
Summaries are generated and may contain mistakes; the official description above is the record.
