# CVE-2026-61597: djust is vulnerable to stored/reflected XSS via javascript: URLs in built-in component template tags


- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-4mf4-73j6-mvrw, PYSEC-2026-4037

## What is CVE-2026-61597?

CVE-2026-61597 is a medium-severity vulnerability in djust-org djust, published on 16 Sep 2026. 

### Official description

djust provides Phoenix LiveView-style reactive server-side rendering for Django with Rust-powered performance. Prior to version 1.0.7, many djust built-in component template tags (`djust.components.templatetags.*`) render a developer/user-supplied URL into an `href` / `action` attribute, HTML-escaping it with `conditional_escape` but never validating the URL scheme. HTML escaping prevents attribute breakout but does not neutralize a `javascript:` URI (which needs no escapable characters), so a URL value of `javascript:alert(document.cookie)` lands verbatim in `<a href="javascript:alert(document.cookie)">` and executes in the victim's session on click. Version 1.0.7 contains a fix. As a workaround, do not pass user-controllable URLs to the affected built-in component tags; pre-validate URL schemes in application code before binding them to component arguments.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-61597?

3 open source packages ship an affected version, including djust.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djust` | PyPI | All versions | 1.0.7 |
| `djust` | PyPI | All versions | 1.0.7 |
| `djust` | PyPI | All versions | 1.0.7 |

## How do I fix CVE-2026-61597?

Upgrade djust to 1.0.7 or later.

## Is CVE-2026-61597 being exploited?

There is no known exploitation of CVE-2026-61597 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61597 and fix it if it is affected.

What it is: CVE-2026-61597 is a medium-severity vulnerability in djust-org djust, published on 16 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-61597 in the wild and no public exploit code.

Affected packages and fixed versions:
- djust (PyPI): affected all versions; fixed in 1.0.7
- djust (PyPI): affected all versions; fixed in 1.0.7
- djust (PyPI): affected all versions; fixed in 1.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61597/ (Markdown: https://insights.sbomify.com/CVE-2026-61597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61597
- OSV: https://osv.dev/vulnerability/CVE-2026-61597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61597/
Summaries are generated and may contain mistakes; the official description above is the record.
