# CVE-2026-61607: Grav API Plugin: Stored XSS via SVG Upload - API Media Pipeline Bypasses Sanitizer

> An attacker with media write permissions can upload malicious SVGs to execute JavaScript in victim browsers, stealing sessions and performing actions.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026

## What is CVE-2026-61607?

CVE-2026-61607 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-api, published on 19 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grav API Plugin is a RESTful API for Grav CMS that provides full headless access to your site's content. Prior to 1.0.2, the Grav API plugin POST /api/v1/media pipeline in HandlesMediaUploads::processUploadedFile() validates an SVG filename extension but does not invoke Security::sanitizeSVG(). An attacker with api.media.write permission can store an SVG containing JavaScript, and the server returns the file as Content-Type: image/svg+xml so the script executes when a victim opens it, allowing session data theft and authenticated actions. This issue is fixed in version 1.0.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-61607?


## How do I fix CVE-2026-61607?

No fix has been published for CVE-2026-61607 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-61607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61607 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61607 and fix it if it is affected.

What it is: CVE-2026-61607 is a medium-severity cross-site scripting vulnerability in getgrav grav-plugin-api, published on 19 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61607 exists.

Affected product: getgrav grav-plugin-api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61607/ (Markdown: https://insights.sbomify.com/CVE-2026-61607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61607
- OSV: https://osv.dev/vulnerability/CVE-2026-61607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61607/
Summaries are generated and may contain mistakes; the official description above is the record.
