CVE-2026-61609 Pterodactyl's shared global rate-limit key on login and 2FA checkpoint enables unauthenticated panel-wide authentication lockout (DoS)

High 7.5 Published Updated

An unauthenticated attacker can exhaust a shared rate-limit bucket to lock out all users from logging into the Pterodactyl panel.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-61609?

CVE-2026-61609 is a high-severity denial of service vulnerability in pterodactyl panel, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Pterodactyl is a free, open-source game server management panel. From 1.7.0 until 1.13.0, the authentication rate limiter defined in RouteServiceProvider::configureRateLimiting() applied a single global bucket to the login and two-factor checkpoint endpoints instead of keying by IP or account: the fall-through Limit::perMinute(10) covering POST /auth/login and POST /auth/login/checkpoint omitted ->by(), so Laravel derived a constant cache key (md5('authentication')) shared by every request. An unauthenticated attacker sending roughly ten requests per minute from a single IP, most cheaply against the checkpoint endpoint (which has no reCAPTCHA), exhausts the shared counter and causes HTTP 429 for every user attempting to log in or complete two-factor authentication, a panel-wide authentication denial of service that also locks out administrators. This issue is fixed in version 1.13.0.

Weakness: CWE-770

Which versions are affected by CVE-2026-61609?

2 open source packages ship an affected version, including pterodactyl/panel.

PackageAffectedFixed in
pterodactyl/panel PackagistFrom 1.7.01.13.0
pterodactyl/panel PackagistFrom 1.7.01.13.0

How do I fix CVE-2026-61609?

Upgrade pterodactyl/panel to 1.13.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-61609 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61609 exists.

Sources

Also known as GHSA-xvc3-826v-xf47.

Is CVE-2026-61609 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free