# CVE-2026-61625: VictoriaMetrics vmrestore: path traversal via crafted backup part names escapes restore root

> An attacker can craft backup object names with path traversal sequences to write files outside the restore directory during vmrestore operations.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** CLEANSTART-2026-PP41562, GHSA-8q3c-rjr9-xxrp, GO-2026-6366, MINI-2pfg-qhh2-gmf2, MINI-2vfv-2pg9-px9w, MINI-44x2-vg3j-9724, MINI-956q-wvvg-2xrv, MINI-c5h8-p3w6-8r8v, MINI-cp43-gx77-p676, MINI-gx2f-jg7g-3f63, MINI-pxxh-h8pq-5gpc, MINI-rw9g-qrv9-hj33, MINI-wc82-rgp6-4jf9

## What is CVE-2026-61625?

CVE-2026-61625 is a medium-severity path traversal vulnerability in VictoriaMetrics, published on 20 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

VictoriaMetrics is a scalable solution for monitoring and managing time series data. Prior to 1.122.25, 1.136.12, and 1.146.0, vmrestore does not validate backup part path components before using lib/backup/actions/restore.go and lib/backup/fslocal/fslocal.go to write restored data below storageDataPath. An attacker who can supply or modify an S3, GCS, Azure Blob Storage, or other backup source can place .. components in object names. When an operator restores that source, the crafted names can create or overwrite files outside the intended restore root within the filesystem permissions of the vmrestore process. This issue is fixed in versions 1.122.25, 1.136.12, and 1.146.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-61625?

7 open source packages ship an affected version, including github.com/VictoriaMetrics/VictoriaMetrics.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | All versions | 1.122.25, 1.136.12, 1.146.0 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | All versions | 1.122.25 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | All versions | 1.122.25 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.123.0 | 1.136.12 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.123.0 | 1.136.12 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.137.0 | 1.146.0 |
| `github.com/VictoriaMetrics/VictoriaMetrics` | Go | From 1.137.0 | 1.146.0 |

## How do I fix CVE-2026-61625?

Upgrade github.com/VictoriaMetrics/VictoriaMetrics to a fixed version for your release line: 1.122.25, 1.136.12 or 1.146.0.

## Is CVE-2026-61625 being exploited?

There is no known exploitation of CVE-2026-61625 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61625 and fix it if it is affected.

What it is: CVE-2026-61625 is a medium-severity path traversal vulnerability in VictoriaMetrics, published on 20 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-61625 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected all versions; fixed in 1.122.25, 1.136.12, 1.146.0
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected all versions; fixed in 1.122.25
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected all versions; fixed in 1.122.25
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.123.0; fixed in 1.136.12
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.123.0; fixed in 1.136.12
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.137.0; fixed in 1.146.0
- github.com/VictoriaMetrics/VictoriaMetrics (Go): affected from 1.137.0; fixed in 1.146.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61625/ (Markdown: https://insights.sbomify.com/CVE-2026-61625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61625
- OSV: https://osv.dev/vulnerability/CVE-2026-61625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61625/
Summaries are generated and may contain mistakes; the official description above is the record.
