{"answers":{"affected":"2 open source packages ship an affected version, including com.rabbitmq:amqp-client.","exploited":"There is no known exploitation of CVE-2026-61634 in the wild and no public exploit code.","fix":"Upgrade com.rabbitmq:amqp-client to 5.33.0 or later.","what":"CVE-2026-61634 is a denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-61634 and fix it if it is affected.\n\nWhat it is: CVE-2026-61634 is a denial of service vulnerability in rabbitmq-java-client, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-61634 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.0\n- com.rabbitmq:amqp-client (Maven): affected all versions; fixed in 5.33.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-61634/ (Markdown: https://insights.sbomify.com/CVE-2026-61634/index.md)","id":"CVE-2026-61634","markdown":"https://insights.sbomify.com/CVE-2026-61634/index.md","name":"CVE-2026-61634","record":{"aliases":["CLEANSTART-2026-KN86223","DEBIAN-CVE-2026-61634","ECHO-18ae-a032-1738","GHSA-5xwg-cfvj-gff5","MINI-599w-36v5-45p5","MINI-fh8r-cgh7-wxc5","MINI-jg3x-88g9-mv6m","MINI-jq9f-6v46-hfqh","MINI-m59m-2v58-55x2","MINI-mh25-xp3f-7xr6","MINI-p5hv-mm5h-gp37","MINI-p757-hc8g-vgm4","MINI-p7m2-669m-j3cg","MINI-q4fc-2mxp-75p4","MINI-q4w6-wq3r-7xwg","MINI-qqf8-fv9x-vpv2","MINI-v4j4-m9g2-rmxj","MINI-vpp9-x2g2-h84h","MINI-w7wg-w358-m35p","UBUNTU-CVE-2026-61634"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RabbitMQ Java client","requires_auth":"none","summary":"A malicious broker can cause client-side denial of service by sending oversized frames that bypass negotiated limits in the RabbitMQ Java client library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":0,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.0, the AMQP connection tuning path records the negotiated AMQP frame_max value, but src/main/java/com/rabbitmq/client/impl/SocketFrameHandler.java and NettyFrameHandlerFactory continue to validate broker-controlled frame payload lengths against maxInboundMessageBodySize because the negotiated limit is not applied consistently through setMaxInboundFramePayloadSize. A malicious or compromised broker can send a method frame larger than the negotiated frame_max during or after connection establishment, causing the client to allocate and decode a protocol-invalid frame instead of rejecting it with MalformedFrameException. The protocol violation can disrupt the affected connection and cause client-side denial of service. This issue is fixed in version 5.33.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RabbitMQ Java client accepts broker frames larger than the negotiated AMQP frame_max","id":"CVE-2026-61634","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"Wallos: SSRF via Test Email Notification - unvalidated SMTP host/port","id":"CVE-2026-61638"},"packages":[{"ecosystem":"Maven","fixed":["5.33.0"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":null,"source":"GHSA-5xwg-cfvj-gff5"},{"ecosystem":"Maven","fixed":["5.33.0"],"introduced":["0"],"last_affected":[],"package":"com.rabbitmq:amqp-client","purl":"pkg:maven/com.rabbitmq/amqp-client","source":"GHSA-5xwg-cfvj-gff5"}],"prev":{"headline":"NanoMQ: Infinite Loop in UNSUBSCRIBE Decoder Leading to Remote DoS","id":"CVE-2026-61633"},"products":["rabbitmq-java-client"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["rabbitmq"]},"summary":"A malicious broker can cause client-side denial of service by sending oversized frames that bypass negotiated limits in the RabbitMQ Java client library.","url":"https://insights.sbomify.com/CVE-2026-61634/"}