# CVE-2026-61666: websocket-driver: Denial of service via malformed Host header

> A remote attacker can crash a WebSocket server by sending a malformed Host header, causing an unhandled exception in the websocket-driver library.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-61666, GHSA-2x63-gw47-w4mm, MINI-2rpx-65c3-8mvf, MINI-85wv-pwpj-jxwr, UBUNTU-CVE-2026-61666

## What is CVE-2026-61666?

CVE-2026-61666 is a high-severity denial of service vulnerability in faye websocket-driver-ruby, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

websocket-driver is a WebSocket protocol handler with pluggable I/O. Prior to 0.8.2, WebSocket::Driver.server() passes a malformed Host header to URI.parse in lib/websocket/http/request.rb without catching URI::InvalidURIError, allowing a remote client to crash a TCP-backed WebSocket server when the application does not catch the error from parse(). This issue is fixed in version 0.8.2.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-61666?

2 open source packages ship an affected version, including websocket-driver.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `websocket-driver` | RubyGems | All versions | 0.8.2 |
| `websocket-driver` | RubyGems | All versions | 0.8.2 |

## How do I fix CVE-2026-61666?

Upgrade websocket-driver to 0.8.2 or later.

## Is CVE-2026-61666 being exploited?

There is no known exploitation of CVE-2026-61666 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61666 and fix it if it is affected.

What it is: CVE-2026-61666 is a high-severity denial of service vulnerability in faye websocket-driver-ruby, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61666 in the wild and no public exploit code.

Affected packages and fixed versions:
- websocket-driver (RubyGems): affected all versions; fixed in 0.8.2
- websocket-driver (RubyGems): affected all versions; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61666/ (Markdown: https://insights.sbomify.com/CVE-2026-61666/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61666
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61666
- OSV: https://osv.dev/vulnerability/CVE-2026-61666

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61666/
Summaries are generated and may contain mistakes; the official description above is the record.
