CVE-2026-61668 DIRAC: Pilot code downloaded over unverified HTTPS connection
Attackers can execute arbitrary code by intercepting unverified HTTPS downloads of pilot code in the DIRAC distributed computing framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-61668?
CVE-2026-61668 is a high-severity vulnerability in DIRACGrid DIRAC, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
DIRAC is an interware, meaning a software framework for distributed computing. Prior to versions 8.0.79, 9.0.22, and 9.1.10, WorkloadManagementSystem/Utilities/PilotWrapper.py pilotWrapperScript uses ssl._create_unverified_context to download the second-stage pilot.tar archive without TLS certificate verification and downloads the reference checksum through the same unvalidated channel. An attacker able to redirect or intercept a grid site's network traffic through DNS or routing manipulation can substitute both the executable pilot code and its checksum, causing arbitrary code to run in the pilot context with access to pilot proxy credentials. The fixed implementation validates the server certificate through system trust and X509_CERT_DIR or the grid certificate directory. This issue is fixed in versions 8.0.79, 9.0.22, and 9.1.10.
Weakness: CWE-295
Which versions are affected by CVE-2026-61668?
7 open source packages ship an affected version, including dirac and DIRAC.
| Package | Affected | Fixed in |
|---|---|---|
dirac PyPI | From 6.20.1 | 8.0.79, 9.0.22, 9.1.10 |
dirac PyPI | From 6.20.1 | 8.0.79 |
dirac PyPI | From 8.1.0a1 | 9.0.22 |
dirac PyPI | From 9.1.0 | 9.1.10 |
DIRAC PyPI | From 6.20.1 | 8.0.79 |
DIRAC PyPI | From 8.1.0a1 | 9.0.22 |
1 more packages
DIRAC PyPI | From 9.1.0 | 9.1.10 |
How do I fix CVE-2026-61668?
Upgrade dirac to a fixed version for your release line: 8.0.79, 9.0.22 or 9.1.10.
Is CVE-2026-61668 being exploited?
There is no known exploitation of CVE-2026-61668 in the wild and no public exploit code.
Sources
Also known as GHSA-vg99-gr89-qhw9, PYSEC-2026-3464.