# CVE-2026-61668: DIRAC: Pilot code downloaded over unverified HTTPS connection

> Attackers can execute arbitrary code by intercepting unverified HTTPS downloads of pilot code in the DIRAC distributed computing framework.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-vg99-gr89-qhw9, PYSEC-2026-3464

## What is CVE-2026-61668?

CVE-2026-61668 is a high-severity vulnerability in DIRACGrid DIRAC, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DIRAC is an interware, meaning a software framework for distributed computing. Prior to versions 8.0.79, 9.0.22, and 9.1.10, WorkloadManagementSystem/Utilities/PilotWrapper.py pilotWrapperScript uses ssl._create_unverified_context to download the second-stage pilot.tar archive without TLS certificate verification and downloads the reference checksum through the same unvalidated channel. An attacker able to redirect or intercept a grid site's network traffic through DNS or routing manipulation can substitute both the executable pilot code and its checksum, causing arbitrary code to run in the pilot context with access to pilot proxy credentials. The fixed implementation validates the server certificate through system trust and X509_CERT_DIR or the grid certificate directory. This issue is fixed in versions 8.0.79, 9.0.22, and 9.1.10.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-61668?

7 open source packages ship an affected version, including dirac and DIRAC.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dirac` | PyPI | From 6.20.1 | 8.0.79, 9.0.22, 9.1.10 |
| `dirac` | PyPI | From 6.20.1 | 8.0.79 |
| `dirac` | PyPI | From 8.1.0a1 | 9.0.22 |
| `dirac` | PyPI | From 9.1.0 | 9.1.10 |
| `DIRAC` | PyPI | From 6.20.1 | 8.0.79 |
| `DIRAC` | PyPI | From 8.1.0a1 | 9.0.22 |
| `DIRAC` | PyPI | From 9.1.0 | 9.1.10 |

## How do I fix CVE-2026-61668?

Upgrade dirac to a fixed version for your release line: 8.0.79, 9.0.22 or 9.1.10.

## Is CVE-2026-61668 being exploited?

There is no known exploitation of CVE-2026-61668 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61668 and fix it if it is affected.

What it is: CVE-2026-61668 is a high-severity vulnerability in DIRACGrid DIRAC, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61668 in the wild and no public exploit code.

Affected packages and fixed versions:
- dirac (PyPI): affected from 6.20.1; fixed in 8.0.79, 9.0.22, 9.1.10
- dirac (PyPI): affected from 6.20.1; fixed in 8.0.79
- dirac (PyPI): affected from 8.1.0a1; fixed in 9.0.22
- dirac (PyPI): affected from 9.1.0; fixed in 9.1.10
- DIRAC (PyPI): affected from 6.20.1; fixed in 8.0.79
- DIRAC (PyPI): affected from 8.1.0a1; fixed in 9.0.22
- DIRAC (PyPI): affected from 9.1.0; fixed in 9.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61668/ (Markdown: https://insights.sbomify.com/CVE-2026-61668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61668
- OSV: https://osv.dev/vulnerability/CVE-2026-61668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61668/
Summaries are generated and may contain mistakes; the official description above is the record.
