# CVE-2026-61670: microsandbox: Secret values exposed in world-readable process arguments

> Local attackers can read secret API keys and tokens from process arguments in microsandbox, exposing sensitive data on shared hosts.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-m8f5-rh7h-vgg3

## What is CVE-2026-61670?

CVE-2026-61670 is a medium-severity vulnerability in superradcompany microsandbox, published on 18 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

microsandbox is an easy, fast, local-first microVM runtime and library. Prior to 0.5.10, sdk/rust/lib/runtime/spawn.rs serializes NetworkConfig secret values into the --network-config argument and passes per-sandbox secrets through repeated --env arguments accepted by crates/cli/lib/sandbox_cmd.rs. Other local users or co-resident processes can read these values through the host process table, including /proc process command lines on Linux and process listings on Linux and macOS, for the lifetime of the sandbox. Exploitation does not require code execution inside the sandbox or access to the spawning user's session, and can disclose host-side API keys, tokens, and environment secrets on shared hosts, CI runners, and developer systems. This issue is fixed in version 0.5.10.

Weakness: CWE-214 (Invocation of Process Using Visible Sensitive Information)

## Which versions are affected by CVE-2026-61670?

2 open source packages ship an affected version, including microsandbox.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `microsandbox` | crates.io | All versions | 0.5.10 |
| `microsandbox` | crates.io | All versions | 0.5.10 |

## How do I fix CVE-2026-61670?

Upgrade microsandbox to 0.5.10 or later.

## Is CVE-2026-61670 being exploited?

There is no known exploitation of CVE-2026-61670 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61670 and fix it if it is affected.

What it is: CVE-2026-61670 is a medium-severity vulnerability in superradcompany microsandbox, published on 18 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61670 in the wild and no public exploit code.

Affected packages and fixed versions:
- microsandbox (crates.io): affected all versions; fixed in 0.5.10
- microsandbox (crates.io): affected all versions; fixed in 0.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61670/ (Markdown: https://insights.sbomify.com/CVE-2026-61670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61670
- OSV: https://osv.dev/vulnerability/CVE-2026-61670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61670/
Summaries are generated and may contain mistakes; the official description above is the record.
