# CVE-2026-61685: ReactPress has SQL injection via dynamic column names in TypeORM query builders

> Unauthenticated attackers can inject SQL via query parameters in ReactPress API endpoints, potentially reading or modifying database contents.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-wmw4-mw6x-6vfm

## What is CVE-2026-61685?

CVE-2026-61685 is a high-severity SQL injection vulnerability in fecommunity reactpress, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ReactPress is a publishing system for React developers. Prior to version 3.7.0, ReactPress API list endpoints build TypeORM `QueryBuilder` conditions using unsanitized HTTP query parameter names as SQL column identifiers (e.g. `` `article.${key}` ``). TypeORM parameterizes values but not column names, allowing unauthenticated attackers to inject SQL through crafted query string keys. Version 3.7.0 contains a patch. As a workaround, allowlist allowed filter column names before interpolating into SQL.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-61685?

2 open source packages ship an affected version, including @fecommunity/reactpress.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fecommunity/reactpress` | npm | All versions | 3.7.0 |
| `@fecommunity/reactpress` | npm | All versions | 3.7.0 |

## How do I fix CVE-2026-61685?

Upgrade @fecommunity/reactpress to 3.7.0 or later.

## Is CVE-2026-61685 being exploited?

There is no known exploitation of CVE-2026-61685 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61685 and fix it if it is affected.

What it is: CVE-2026-61685 is a high-severity SQL injection vulnerability in fecommunity reactpress, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61685 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fecommunity/reactpress (npm): affected all versions; fixed in 3.7.0
- @fecommunity/reactpress (npm): affected all versions; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61685/ (Markdown: https://insights.sbomify.com/CVE-2026-61685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61685
- OSV: https://osv.dev/vulnerability/CVE-2026-61685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61685/
Summaries are generated and may contain mistakes; the official description above is the record.
