# CVE-2026-61687: hatchet - Unauthenticated OAuth state CSRF / login-CSRF via empty-state collision in ValidateOAuthState

> An attacker can bind a victim's session to an attacker-controlled OAuth identity via empty-state collision, requiring specific auth integrations to be enabled.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-phg3-3g28-wq9v, GO-2026-6535

## What is CVE-2026-61687?

CVE-2026-61687 is a high-severity vulnerability in hatchet-dev hatchet, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Hatchet is a platform for orchestrating background tasks, AI agents, and durable workflows at scale. Prior to 0.91.1, ValidateOAuthState clears the oauth_state_ session value to an empty string after a successful OAuth callback and later accepts an empty state parameter as equal, allowing an unauthenticated attacker to bind a victim's Hatchet session to an attacker-controlled OAuth identity. Exploitation requires the victim to have completed an OAuth flow in the current session and the deployment to enable auth.google.enabled, auth.github.enabled, or the Slack integration. This issue is fixed in version 0.91.1.

Weakness: CWE-384 (Session Fixation), CWE-352 (Cross-Site Request Forgery), CWE-287 (Improper Authentication), CWE-1275 (Sensitive Cookie with Improper SameSite Attribute)

## Which versions are affected by CVE-2026-61687?

3 open source packages ship an affected version, including github.com/hatchet-dev/hatchet and hatchet.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hatchet-dev/hatchet` | Go | All versions | 0.91.2 |
| `hatchet` | Go | All versions | 0.91.1 |
| `hatchet` | Go | All versions | 0.91.1 |

## How do I fix CVE-2026-61687?

Upgrade github.com/hatchet-dev/hatchet to 0.91.2 or later.

## Is CVE-2026-61687 being exploited?

There is no known exploitation of CVE-2026-61687 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61687 and fix it if it is affected.

What it is: CVE-2026-61687 is a high-severity vulnerability in hatchet-dev hatchet, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-61687 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hatchet-dev/hatchet (Go): affected all versions; fixed in 0.91.2
- hatchet (Go): affected all versions; fixed in 0.91.1
- hatchet (Go): affected all versions; fixed in 0.91.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61687/ (Markdown: https://insights.sbomify.com/CVE-2026-61687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61687
- OSV: https://osv.dev/vulnerability/CVE-2026-61687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61687/
Summaries are generated and may contain mistakes; the official description above is the record.
