# CVE-2026-61690: Grav: Decompression Bomb via ZipArchiver - Missing Extraction Limits

> Attackers can cause denial of service in Grav by uploading malicious archives that bypass extraction limits, exhausting disk resources.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 25 Aug 2026

## What is CVE-2026-61690?

CVE-2026-61690 is a medium-severity denial of service vulnerability in getgrav grav, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.1, Grav ZipArchiver::extract() in system/src/Grav/Common/Filesystem/ZipArchiver.php passes archives to ZipArchive::extractTo() without enforcing the system.gpm.archive uncompressed-size, file-count, or nesting-depth limits. Code using Archiver::create('zip') to extract an attacker-controlled archive can exhaust disk space or inodes and make the site unavailable. This issue is fixed in version 2.0.1.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-61690?


## How do I fix CVE-2026-61690?

Upgrade to a fixed version.

## Is CVE-2026-61690 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61690 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61690 and fix it if it is affected.

What it is: CVE-2026-61690 is a medium-severity denial of service vulnerability in getgrav grav, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61690 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61690/ (Markdown: https://insights.sbomify.com/CVE-2026-61690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61690
- OSV: https://osv.dev/vulnerability/CVE-2026-61690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61690/
Summaries are generated and may contain mistakes; the official description above is the record.
