# CVE-2026-61695: Wire Swift runtime: negative LENGTH_DELIMITED length in skipGroup() crashes any protobuf-decoding service

> Attackers can crash Swift services decoding untrusted protobuf data by exploiting a negative length check in the Wire library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-86wm-r4c5-2rc9

## What is CVE-2026-61695?

CVE-2026-61695 is a high-severity vulnerability in square wire, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Wire provides gRPC and protocol buffers for Android, Kotlin, Swift, and Java. Prior to 6.4.1 and 7.0.0-alpha04, Wire's Swift runtime ProtoReader.skipGroup(expectedEndTag:unknownFieldsWriter:) accepts a negative length for a LENGTH_DELIMITED field inside an unknown START_GROUP field. ProtoReader.readData() forwards the negative count to ReadBuffer.readData(count:), whose upper-bound-only check permits the value to reach Foundation Data(bytes:count:) and trigger an unrecoverable process trap instead of a catchable ProtoDecoder.Error. Any Swift process decoding untrusted protobuf bytes can be crashed without authentication, user interaction, or knowledge of the target schema. This issue is fixed in versions 6.4.1 and 7.0.0-alpha04.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-61695?

2 open source packages ship an affected version, including github.com/square/wire.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/square/wire` | SwiftURL | All versions | 6.4.1 |
| `github.com/square/wire` | SwiftURL | All versions | 6.4.1 |

## How do I fix CVE-2026-61695?

Upgrade github.com/square/wire to 6.4.1 or later.

## Is CVE-2026-61695 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61695 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61695 and fix it if it is affected.

What it is: CVE-2026-61695 is a high-severity vulnerability in square wire, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61695 exists.

Affected packages and fixed versions:
- github.com/square/wire (SwiftURL): affected all versions; fixed in 6.4.1
- github.com/square/wire (SwiftURL): affected all versions; fixed in 6.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61695/ (Markdown: https://insights.sbomify.com/CVE-2026-61695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61695
- OSV: https://osv.dev/vulnerability/CVE-2026-61695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61695/
Summaries are generated and may contain mistakes; the official description above is the record.
