# CVE-2026-61700: MariaDB Connector/J does not enforce allowLocalInfile=false on server-initiated LOCAL INFILE requests

> A malicious server can force the MariaDB Java connector to leak a specific file already selected by the application, bypassing the allowLocalInfile=false setting.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** CLEANSTART-2026-ZS53659, DEBIAN-CVE-2026-61700, ECHO-e63a-ac26-7d97, GHSA-wxmm-q36w-r9xj, MINI-2hj9-hwm9-w855, MINI-49cc-r7hh-m47q, MINI-4wcg-wwxv-hr3c, MINI-5w3f-3g66-2r42, MINI-6j25-pwq5-w58v, MINI-86gc-vcgx-jc22, MINI-f6jc-4rqf-3vvp, MINI-fc5p-v4cx-j498, MINI-g2h5-8hp8-prvh, MINI-gwv3-h6p2-p4pv, MINI-hg6h-2jmp-5x43, MINI-hgcm-wc33-7j8q, MINI-mvvf-6h99-chwf, MINI-rhrm-fqch-7737, MINI-w8fr-mfgx-hpwj, UBUNTU-CVE-2026-61700

## What is CVE-2026-61700?

CVE-2026-61700 is a low-severity vulnerability in mariadb-corporation mariadb-connector-j, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MariaDB Connector/J is used to connect applications developed in Java to MariaDB and MySQL databases. Prior to 2.7.14, 3.3.5, 3.4.3, and 3.5.9, ClientMessage.readPacket processes a server-initiated LOCAL INFILE protocol packet 0xfb without enforcing allowLocalInfile=false. When an application sends a LOAD DATA LOCAL INFILE COM_QUERY, a rogue or man-in-the-middle server can echo the same filename and cause the connector to transmit that file despite the disabled option. The server cannot redirect the request to an arbitrary path and can receive only the exact file already selected by the application, so exploitation requires an application that actively loads sensitive data over an untrusted connection. This issue is fixed in versions 2.7.14, 3.3.5, 3.4.3, and 3.5.9.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-61700?

8 open source packages ship an affected version, including org.mariadb.jdbc:mariadb-java-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | All versions | 2.7.14 |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | All versions | 2.7.14 |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | From 3.0.0 | 3.3.5 |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | From 3.0.0 | 3.3.5 |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | From 3.4.0 | 3.4.3 |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | From 3.4.0 | 3.4.3 |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | From 3.5.0 | 3.5.9 |
| `org.mariadb.jdbc:mariadb-java-client` | Maven | From 3.5.0 | 3.5.9 |

## How do I fix CVE-2026-61700?

Upgrade org.mariadb.jdbc:mariadb-java-client to a fixed version for your release line: 2.7.14, 3.3.5, 3.4.3 or 3.5.9.

## Is CVE-2026-61700 being exploited?

There is no known exploitation of CVE-2026-61700 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61700 and fix it if it is affected.

What it is: CVE-2026-61700 is a low-severity vulnerability in mariadb-corporation mariadb-connector-j, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61700 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.mariadb.jdbc:mariadb-java-client (Maven): affected all versions; fixed in 2.7.14
- org.mariadb.jdbc:mariadb-java-client (Maven): affected all versions; fixed in 2.7.14
- org.mariadb.jdbc:mariadb-java-client (Maven): affected from 3.0.0; fixed in 3.3.5
- org.mariadb.jdbc:mariadb-java-client (Maven): affected from 3.0.0; fixed in 3.3.5
- org.mariadb.jdbc:mariadb-java-client (Maven): affected from 3.4.0; fixed in 3.4.3
- org.mariadb.jdbc:mariadb-java-client (Maven): affected from 3.4.0; fixed in 3.4.3
- org.mariadb.jdbc:mariadb-java-client (Maven): affected from 3.5.0; fixed in 3.5.9
- org.mariadb.jdbc:mariadb-java-client (Maven): affected from 3.5.0; fixed in 3.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61700/ (Markdown: https://insights.sbomify.com/CVE-2026-61700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61700
- OSV: https://osv.dev/vulnerability/CVE-2026-61700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61700/
Summaries are generated and may contain mistakes; the official description above is the record.
