# CVE-2026-61709: OpenFGA: ListUsers returns a deliberately-excluded user when a `but not` exclusion under a type-bound wildcard is intersected (`and`) with another relation that also grants that user

> Attackers can bypass authorization checks in OpenFGA's ListUsers API when specific intersection and exclusion logic is used, gaining unauthorized access.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** CLEANSTART-2026-LI79671, ECHO-cd63-9789-8fd2, GHSA-g3pg-frfm-pr2m, GO-2026-6488, MINI-2m3c-29mw-r27x, MINI-2p49-w43h-pgh3, MINI-2rmx-whcm-jjfv, MINI-47r4-r96q-2jpg, MINI-59q3-wmfx-3f48, MINI-6h25-v7jm-vq32, MINI-6h4h-4jmh-3w9p, MINI-82x5-4gvm-f6gw, MINI-8v8w-5jqj-289q, MINI-9wv3-3xv8-mh9x, MINI-f66q-gq5g-rrhq, MINI-gqxf-c3w5-7xv2, MINI-gr44-xf83-mqqq, MINI-h4jq-pg3v-qcf9, MINI-h63j-m4jp-9x7x, MINI-phrh-437h-h49x, MINI-r3x9-vw98-r4fw, MINI-rr2w-9mh2-gf42, MINI-vfmv-9jjj-qjrg, MINI-w83j-qrmr-ggff, MINI-wm74-7c73-244q, MINI-xp7c-x249-f25f

## What is CVE-2026-61709?

CVE-2026-61709 is a medium-severity missing authorization vulnerability in openfga, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is an authorization and permission engine built for developers. Prior to 1.18.1, the ListUsers API could return a user that should have been excluded when an authorization relation used an intersection containing a base but not excluded operand, the base was granted through a type-bound public wildcard, and the excluded user also had a concrete tuple through another intersection operand. In pkg/server/commands/listusers/list_users_rpc.go, expandIntersection counted the concrete tuple and wildcard without first rejecting entries in excludedUsersMap. Applications that used ListUsers to enumerate or enforce access could therefore treat an excluded user as authorized. This issue is fixed in version 1.18.1.

Weakness: CWE-863 (Incorrect Authorization), CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2026-61709?

3 open source packages ship an affected version, including github.com/openfga/openfga.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.18.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.18.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.18.1 |

## How do I fix CVE-2026-61709?

Upgrade github.com/openfga/openfga to 1.18.1 or later.

## Is CVE-2026-61709 being exploited?

There is no known exploitation of CVE-2026-61709 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61709 and fix it if it is affected.

What it is: CVE-2026-61709 is a medium-severity missing authorization vulnerability in openfga, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61709 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61709/ (Markdown: https://insights.sbomify.com/CVE-2026-61709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61709
- OSV: https://osv.dev/vulnerability/CVE-2026-61709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61709/
Summaries are generated and may contain mistakes; the official description above is the record.
