# CVE-2026-61711: BuildKit: Custom frontend could bypass Seccomp/AppArmor

> A custom frontend can bypass Seccomp and AppArmor protections in BuildKit by submitting an invalid security mode, weakening container isolation.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 20 Aug 2026
- **Also known as:** AZL-97032, ECHO-7696-5a12-0f6d, GHSA-7236-3392-c5c6, GO-2026-6255, MINI-2g6v-cvg4-98cx, MINI-2v6m-f974-fqvf, MINI-2vjx-26f4-3mc8, MINI-33pc-466v-76wj, MINI-3ffh-9rjm-j5r3, MINI-3h8g-c775-54pc, MINI-3m85-8fq7-jrwv, MINI-3mf4-mw3q-3jg7, MINI-46xh-hrfh-p88v, MINI-5f9f-w5f4-w6p4, MINI-7vjw-3fff-rpr5, MINI-7xx7-93qr-fcfw, MINI-82fr-gw73-rwxf, MINI-8547-2f3p-ccw9, MINI-8773-69vg-484m, MINI-8j7w-9mrg-3795, MINI-8rfj-8x95-hv4q, MINI-953w-wmc4-rwc9, MINI-c3jr-pcwr-cgm3, MINI-cmhg-7phf-85mw, MINI-crm2-vw5j-3f6w, MINI-f482-jcv3-9f7g, MINI-fh7f-8cmw-h3h9, MINI-ggj7-r4rx-vpcw, MINI-gh48-r3gm-4hc8, MINI-grgx-9mqm-p4pj, MINI-h67m-w84w-p53w, MINI-h68f-q9w4-xx7f, MINI-h6rp-7r2h-jgjc, MINI-h7x9-j657-5cwr, MINI-hfr8-4hv8-wqc8, MINI-hv6c-jj5v-6xgw, MINI-jwjw-7cmp-qcmw, MINI-m24f-hx84-rc7j, MINI-m9cv-vp7h-2g5v, MINI-mmj9-j2xg-4w68, MINI-p7hq-frcf-2m4q, MINI-q6xp-j8g3-h29w, MINI-qg77-r5h5-xvmc, MINI-v5pv-3qwc-5w5p, MINI-vgrh-33r6-wfvj, MINI-w7wx-jc39-6vmj, MINI-xv6r-pg4m-3ffw

## What is CVE-2026-61711?

CVE-2026-61711 is a medium-severity vulnerability in moby buildkit, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

BuildKit is a toolkit for converting source code to build artifacts in an efficient, expressive and repeatable manner. Prior to 0.31.1, a custom frontend could place an invalid SecurityMode value in a crafted build request, and executor/oci/spec_linux.go treated the unsupported value as a non-sandbox mode without requiring the security.insecure entitlement. This disabled Seccomp and AppArmor protections for the build container even though Linux capabilities remained restricted. This issue is fixed in version 0.31.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-61711?

3 open source packages ship an affected version, including github.com/moby/buildkit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/moby/buildkit` | Go | All versions | 0.31.1 |
| `github.com/moby/buildkit` | Go | All versions | 0.31.1 |
| `github.com/moby/buildkit` | Go | All versions | 0.31.1 |

## How do I fix CVE-2026-61711?

Upgrade github.com/moby/buildkit to 0.31.1 or later.

## Is CVE-2026-61711 being exploited?

There is no known exploitation of CVE-2026-61711 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61711 and fix it if it is affected.

What it is: CVE-2026-61711 is a medium-severity vulnerability in moby buildkit, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61711 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/moby/buildkit (Go): affected all versions; fixed in 0.31.1
- github.com/moby/buildkit (Go): affected all versions; fixed in 0.31.1
- github.com/moby/buildkit (Go): affected all versions; fixed in 0.31.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61711/ (Markdown: https://insights.sbomify.com/CVE-2026-61711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61711
- OSV: https://osv.dev/vulnerability/CVE-2026-61711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61711/
Summaries are generated and may contain mistakes; the official description above is the record.
