{"answers":{"affected":"3 open source packages ship an affected version, including lightrag-hku.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61736 exists.","fix":"Upgrade lightrag-hku to 1.5.4 or later.","what":"CVE-2026-61736 is a critical vulnerability in HKUDS LightRAG, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-61736 and fix it if it is affected.\n\nWhat it is: CVE-2026-61736 is a critical vulnerability in HKUDS LightRAG, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61736 exists.\n\nAffected packages and fixed versions:\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-61736/ (Markdown: https://insights.sbomify.com/CVE-2026-61736/index.md)","id":"CVE-2026-61736","markdown":"https://insights.sbomify.com/CVE-2026-61736/index.md","name":"CVE-2026-61736","record":{"aliases":["GHSA-6x6h-qqr7-855w","PYSEC-2026-3474"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"LightRAG server","requires_auth":"none","summary":"Default CORS settings allow any website to make authenticated requests, enabling attackers to steal data or delete documents.","user_interaction":"required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-942","name":"Permissive Cross-domain Security Policy with Untrusted Domains"}],"description":"LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.4, the server defaults to CORS_ORIGINS=* combined with allow_credentials=True in lightrag/api/lightrag_server.py, causing Starlette CORSMiddleware to effectively whitelist every origin for credentialed cross-origin requests. Any malicious website visited by an authenticated LightRAG user can silently make authenticated API requests, exfiltrating documents and knowledge graph data or performing destructive actions such as deleting the document store. This vulnerability is fixed in 1.5.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-61736.yaml","stars":null,"title":"LightRAG \u003c= 1.5.3 - Credentialed CORS Wildcard"}],"tier":"weaponised"},"has_fix":true,"headline":"LightRAG: CORS Wildcard + Credentials Enables Any-Origin Credentialed Requests","id":"CVE-2026-61736","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"misconfiguration","year":"2026"},"n_packages":3,"n_references":6,"next":{"headline":"LightRAG is Vulnerable to Authentication Bypass: hardcoded DEFAULT_TOKEN_SECRET and public /auth-status defeat LIGHTRAG_API_KEY protection","id":"CVE-2026-61740"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":null,"source":"GHSA-6x6h-qqr7-855w"},{"ecosystem":"PyPI","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":"pkg:pypi/lightrag-hku","source":"GHSA-6x6h-qqr7-855w"},{"ecosystem":"PyPI","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":"pkg:pypi/lightrag-hku","source":"PYSEC-2026-3474"}],"prev":{"headline":"Decepticon: Role-boundary forgery via ChatML special-token literals in web crawl output composed into LLM context","id":"CVE-2026-61732"},"products":["LightRAG"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["HKUDS"]},"summary":"Default CORS settings allow any website to make authenticated requests, enabling attackers to steal data or delete documents.","url":"https://insights.sbomify.com/CVE-2026-61736/"}