# CVE-2026-61736: LightRAG: CORS Wildcard + Credentials Enables Any-Origin Credentialed Requests

> Default CORS settings allow any website to make authenticated requests, enabling attackers to steal data or delete documents.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-6x6h-qqr7-855w, PYSEC-2026-3474

## What is CVE-2026-61736?

CVE-2026-61736 is a critical vulnerability in HKUDS LightRAG, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.4, the server defaults to CORS_ORIGINS=* combined with allow_credentials=True in lightrag/api/lightrag_server.py, causing Starlette CORSMiddleware to effectively whitelist every origin for credentialed cross-origin requests. Any malicious website visited by an authenticated LightRAG user can silently make authenticated API requests, exfiltrating documents and knowledge graph data or performing destructive actions such as deleting the document store. This vulnerability is fixed in 1.5.4.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-61736?

3 open source packages ship an affected version, including lightrag-hku.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lightrag-hku` | PyPI | All versions | 1.5.4 |
| `lightrag-hku` | PyPI | All versions | 1.5.4 |
| `lightrag-hku` | PyPI | All versions | 1.5.4 |

## How do I fix CVE-2026-61736?

Upgrade lightrag-hku to 1.5.4 or later.

## Is CVE-2026-61736 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61736 exists.

Public exploit code:

- LightRAG <= 1.5.3 - Credentialed CORS Wildcard (nuclei): http/cves/2026/CVE-2026-61736.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61736 and fix it if it is affected.

What it is: CVE-2026-61736 is a critical vulnerability in HKUDS LightRAG, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61736 exists.

Affected packages and fixed versions:
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4
- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61736/ (Markdown: https://insights.sbomify.com/CVE-2026-61736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61736
- OSV: https://osv.dev/vulnerability/CVE-2026-61736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61736/
Summaries are generated and may contain mistakes; the official description above is the record.
