{"answers":{"affected":"3 open source packages ship an affected version, including lightrag-hku.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61740 exists.","fix":"Upgrade lightrag-hku to 1.5.4 or later.","what":"CVE-2026-61740 is a critical authentication bypass vulnerability in HKUDS LightRAG, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-61740 and fix it if it is affected.\n\nWhat it is: CVE-2026-61740 is a critical authentication bypass vulnerability in HKUDS LightRAG, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61740 exists.\n\nAffected packages and fixed versions:\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4\n- lightrag-hku (PyPI): affected all versions; fixed in 1.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-61740/ (Markdown: https://insights.sbomify.com/CVE-2026-61740/index.md)","id":"CVE-2026-61740","markdown":"https://insights.sbomify.com/CVE-2026-61740/index.md","name":"CVE-2026-61740","record":{"aliases":["GHSA-f4vv-55c2-5789","PYSEC-2026-3475"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"LightRAG Python library","requires_auth":"none","summary":"Remote attackers can bypass API key authentication in LightRAG to read, modify, or delete documents and query data when specific configuration conditions are met.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-798","name":"Use of Hard-coded Credentials"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.4, when LightRAG is deployed with LIGHTRAG_API_KEY set but AUTH_ACCOUNTS unset, X-API-Key protection can be bypassed because lightrag/api/auth.py falls back to a hardcoded DEFAULT_TOKEN_SECRET, /auth-status and /login can mint guest JWTs, and combined_dependency in lightrag/api/utils_api.py accepts a valid guest token before checking the API key. A remote unauthenticated attacker can call endpoints guarded by combined_auth, including document read, upload, deletion, graph mutation, and query endpoints. This vulnerability is fixed in 1.5.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"LightRAG is Vulnerable to Authentication Bypass: hardcoded DEFAULT_TOKEN_SECRET and public /auth-status defeat LIGHTRAG_API_KEY protection","id":"CVE-2026-61740","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"http4s-scala-xml has an XML External Entity (XXE) processing issue","id":"CVE-2026-61741"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":null,"source":"GHSA-f4vv-55c2-5789"},{"ecosystem":"PyPI","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":"pkg:pypi/lightrag-hku","source":"GHSA-f4vv-55c2-5789"},{"ecosystem":"PyPI","fixed":["1.5.4"],"introduced":["0"],"last_affected":[],"package":"lightrag-hku","purl":"pkg:pypi/lightrag-hku","source":"PYSEC-2026-3475"}],"prev":{"headline":"LightRAG: CORS Wildcard + Credentials Enables Any-Origin Credentialed Requests","id":"CVE-2026-61736"},"products":["LightRAG"],"published":"2026-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["HKUDS"]},"summary":"Remote attackers can bypass API key authentication in LightRAG to read, modify, or delete documents and query data when specific configuration conditions are met.","url":"https://insights.sbomify.com/CVE-2026-61740/"}