# CVE-2026-61781: pg_partman has privilege escalation through SQL injection in create_partition_time()

> Privileged users can inject SQL into pg_partman configuration, leading to superuser privilege escalation and potential OS command execution.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-61781, ECHO-eee1-bd2d-6964, GHSA-742w-3j7c-qwvp, UBUNTU-CVE-2026-61781

## What is CVE-2026-61781?

CVE-2026-61781 is a critical SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, create_partition_time() reads the writable part_config.time_encoder text value and interpolates it without identifier quoting into a dynamically executed SELECT statement. A role with the documented partman_user INSERT and UPDATE privileges can store SQL rather than a function name. When pg_partman_bgw later creates a child partition for a text- or UUID-keyed set, the worker executes the stored SQL with pg_partman_bgw.role privileges, which default to PostgreSQL superuser. The persistent configuration row can repeatedly restore elevated access on later maintenance ticks, and successful exploitation can permit database-wide compromise and operating-system command execution as the PostgreSQL service account. This issue is fixed in version 5.5.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-61781?


## How do I fix CVE-2026-61781?

Upgrade to a fixed version.

## Is CVE-2026-61781 being exploited?

There is no known exploitation of CVE-2026-61781 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61781 and fix it if it is affected.

What it is: CVE-2026-61781 is a critical SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61781 in the wild and no public exploit code.

Affected product: pgpartman pg_partman. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61781/ (Markdown: https://insights.sbomify.com/CVE-2026-61781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61781
- OSV: https://osv.dev/vulnerability/CVE-2026-61781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61781/
Summaries are generated and may contain mistakes; the official description above is the record.
