# CVE-2026-61782: @rsdoctor/rspack-plugin has Unauthenticated HTTP API that Exposes Project Source Code and Build Metadata

> Remote attackers can access unauthenticated HTTP APIs to steal source code and build metadata from Rsdoctor instances running on all network interfaces.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-jmg2-rcxh-w8q3

## What is CVE-2026-61782?

CVE-2026-61782 is a high-severity vulnerability in web-infra-dev rsdoctor, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rsdoctor is a build analyzer tailored for projects built with Rspack. Prior to version 1.5.16, the default Rsdoctor report HTTP server started by `@rsdoctor/rspack-plugin` binds to all network interfaces (`0.0.0.0`) and serves a `POST /api/data/key` endpoint with no authentication and wildcard CORS (`Access-Control-Allow-Origin: *`). Any network-adjacent or remote attacker can send a single unauthenticated request to retrieve the full source code of all compiled JavaScript modules (`moduleCodeMap`), serialized build configuration (`configs`), error details, and other sensitive build metadata. This server is enabled by default in non-CI environments, requiring no special configuration from the victim developer. Version 1.5.16 patches the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-61782?

2 open source packages ship an affected version, including @rsdoctor/rspack-plugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@rsdoctor/rspack-plugin` | npm | All versions | 1.5.16 |
| `@rsdoctor/rspack-plugin` | npm | All versions | 1.5.16 |

## How do I fix CVE-2026-61782?

Upgrade @rsdoctor/rspack-plugin to 1.5.16 or later.

## Is CVE-2026-61782 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61782 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61782 and fix it if it is affected.

What it is: CVE-2026-61782 is a high-severity vulnerability in web-infra-dev rsdoctor, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61782 exists.

Affected packages and fixed versions:
- @rsdoctor/rspack-plugin (npm): affected all versions; fixed in 1.5.16
- @rsdoctor/rspack-plugin (npm): affected all versions; fixed in 1.5.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61782/ (Markdown: https://insights.sbomify.com/CVE-2026-61782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61782
- OSV: https://osv.dev/vulnerability/CVE-2026-61782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61782/
Summaries are generated and may contain mistakes; the official description above is the record.
